Telesign system status

Telesign system status history

This page offers API uptime information for Telesign services, in addition to incident history reports and service issues alerts.

Active events

See more

Operational

Degraded performance

Partial Outage

Major Outage

Under maintenance

Service disruption for Phone ID Subscriber Status and Number Deactivation - Philippines
Incident Report for Telesign System
Resolved
We received notification that the issue previously noticed in Philippines affecting Phone ID Subscriber Status and Number Deactivation has been resolved. End users should no longer experience delays, as all services are back to functioning properly.
Posted Feb 04, 2025 - 06:05 PST
Update
We are continuing to investigate this issue.
Posted Feb 04, 2025 - 02:35 PST
Investigating
We have received notification that services for Phone ID Subscriber Status and Number Deactivation in Philippines is experiencing delays. We will inform you as soon as we receive a resolution.
Posted Feb 04, 2025 - 02:34 PST