Telesign system status

Telesign system status history

This page offers API uptime information for Telesign services, in addition to incident history reports and service issues alerts.

Active events

See more

Operational

Degraded performance

Partial Outage

Major Outage

Under maintenance

Service disruption for phone ID Sim Swap - United States

Incident Report for Telesign System

Resolved

Date: 04/30/25
Start Time: 05:05 PM PDT
End Time: 06:10 PM PDT

We received notification from our partner that the issue previously noticed in the United States. has been resolved. End users should no longer experience delays, as all services are back to functioning properly.
Posted Apr 30, 2025 - 19:16 PDT

Investigating

We have received notification that services for Phone ID Sim Swap - United States are experiencing delays.

We will inform you as soon as we receive a resolution.
Posted Apr 30, 2025 - 18:03 PDT
This incident affected: Phone ID SIM Swap - NA & LATAM (United States).