Telesign system status

Telesign system status history

This page offers API uptime information for Telesign services, in addition to incident history reports and service issues alerts.

Active events

See more

Operational

Degraded performance

Partial Outage

Major Outage

Under maintenance

Regulatory Update - πŸ“’ Important Announcement: Mandatory Sender ID Registration – Burundi (Lumitel)

Scheduled for Sep 17, 2025, 02:05 PDT  -  Jan 20, 2026, 01:05 PST

Update

We will be undergoing scheduled maintenance during this time.
Posted Sep 18, 2025 - 20:23 PDT

Scheduled

To comply with Lumitel (Burundi) regulatory requirements effective 1 October 2025, all clients must register their Sender IDs before sending traffic.

#Sender ID Requirements:
Format: Alphanumeric only (the β€œ-” dash character is not supported)

#Message content requirement:
Brand name is explicitly included in the message content.

Estimated approval time: 7 days

#Required Details & Documents for Registration:
1. Sender ID
2. Message Content / Templates
3. Company Name
4. Company Website
5. Service Description (Business Category)
6. Lumitel LOA
7. Brand-owner's Business certificate/license
8. Template excel file

βœ… Key Points:
Sender ID registration will be mandatory from 1 October 2025.
Clients wishing to register new Sender IDs should prepare the above documentation.
Generic Sender IDs remain available, so no traffic disruptions are expected.

βœ… Action Required:
Please begin preparations and submit your Sender ID registration requests as early as possible to ensure approval before the 1 October 2025 enforcement date.

Thank you for your attention to this important update.
Posted Sep 17, 2025 - 02:04 PDT
This scheduled maintenance affects: Regulatory Updates (EMEA).