Telesign system status

Telesign system status history

This page offers API uptime information for Telesign services, in addition to incident history reports and service issues alerts.

Active events

⤢See more

Operational

Degraded performance

Partial Outage

Major Outage

Under maintenance

Operator Alert - Ghana (GH) - ScanCom Ltd (MTN) (620/01)

Incident Report for Telesign System

Resolved

Start Time: 11:17 PM - 03/02/25
End Time: 00:54 AM - 03/03/25

We received notification that the network issues previously reported by Ghana (GH) - ScanCom Ltd (MTN) (620/01) from Ghana (GH) have been resolved. Ghana (GH) - ScanCom Ltd (MTN) (620/01) end users should no longer experience delays receiving SMS messages as all services are back to functioning properly.

SF 00959999
Posted Mar 03, 2025 - 01:19 PST

Investigating

Start Time: 11:17 PM - 03/02/25
End Time: Ongoing

We received notification that Ghana (GH) - ScanCom Ltd (MTN) (620/01) from Ghana (GH) is currently experiencing network issues, and this may cause a delay in the delivery of SMS messages. We will inform you once the operator has come to a resolution.

SF 00959999
Posted Mar 02, 2025 - 23:28 PST
This incident affected: SMS/SMS Verify - EMEA (EMEA - All countries).