We received notification that quality degradation for United States Cellular Corp (311/220;580) has been resolved.
We'd like to apologize for any inconvenience and appreciate your patience during this service interruption. If you have any questions, please contact support@telesign.com.
SF 00977694
Posted Apr 08, 2025 - 18:21 PDT
Update
US/CA Operator - United States Cellular Corp (311/220;580) Quality degradation
We received notification that quality degradation for United States Cellular Corp (311/220;580) has been resolved.
We'd like to apologize for any inconvenience and appreciate your patience during this service interruption. If you have any questions, please contact support@telesign.com.
SF 00977694
Posted Apr 08, 2025 - 18:20 PDT
Investigating
Issue: US/CA Operator - United States Cellular Corp (311/220;580) Quality degradation
Start Time: 05:07 PM PDT - 04/08/25 End Time: TBA
Summary:
We currently experience quality degradation toward United States (US) - United States Cellular Corp (311/220;580). SMS messages towards this operator may face delays or difficulties in delivery.
Telesign is engaged with carrier partners for updates on resolution. We'd like to apologize for any inconvenience and appreciate your patience during this service interruption.