Telesign system status

Telesign system status history

This page offers API uptime information for Telesign services, in addition to incident history reports and service issues alerts.

Active events

See more

Operational

Degraded performance

Partial Outage

Major Outage

Under maintenance

Phone ID Contact Match, Sim Swap and Subscriber Status Service Alert - Canada

Incident Report for Telesign System

Resolved

Date: 04/16/2025
Start Time: 10:00 AM PDT
End Time: 01:56 PM PDT

We received notification from our partner that the issue previously noticed in Canada, for Phone ID Contact Match, Sim Swap and Subscriber Status Service, has been resolved. End users should no longer experience delays, as all services are back to functioning properly.
Posted Apr 16, 2025 - 14:58 PDT

Identified

Date: 04/16/2025
Start Time: 10:00 AM PDT
End Time: Ongoing

We received notification from our partner that Phone ID Contact Match, Sim Swap and Subscriber Status are currently having issues in Canada, which may cause some delays. We will inform you once there is a resolution.

We'd like to apologize for any inconvenience and appreciate your patience during this service window.

If you have any questions, please contact us at support@telesign.com.
Posted Apr 16, 2025 - 12:51 PDT
This incident affected: Phone ID SIM Swap - NA & LATAM (Canada) and Phone ID Additional add-ons (Contact match, Subscriber status).