Telesign system status

Telesign system status history

This page offers API uptime information for Telesign services, in addition to incident history reports and service issues alerts.

Active events

See more

Operational

Degraded performance

Partial Outage

Major Outage

Under maintenance

Delays for Phone ID Contact Match and Subscriber Status - Canada

Incident Report for Telesign System

Resolved

This incident has been resolved.
Posted Feb 28, 2025 - 04:38 PST

Identified

We have received notification that services for Phone ID Contact Match and Subscriber Status - Canada are experiencing delays. We will inform you as soon as we receive a resolution.
Posted Feb 28, 2025 - 00:42 PST
This incident affected: Phone ID Additional add-ons (Contact match, Subscriber status).