Telesign system status

Telesign system status history

This page offers API uptime information for Telesign services, in addition to incident history reports and service issues alerts.

Active events

See more














Operational

Degraded performance

Partial Outage

Major Outage

Under maintenance

Operational

Degraded performance

Partial Outage

Major Outage

Under maintenance

Operational

Degraded performance

Partial Outage

Major Outage

Under maintenance

Operational

Degraded performance

Partial Outage

Major Outage

Under maintenance

Operational

Degraded performance

Partial Outage

Major Outage

Under maintenance

Possible Delays

Incident Report for Telesign System

Resolved

03/31/2025
Start Time: 02:57 AM PDT
End time: 03:16 AM PDT

Dear Customers and Partners,

The instability on our platform has been resolved

Our team is currently reviewing the root cause and will provide additional information once we have completed the investigation.

If you have any questions, please contact us at support@telesign.com.
Posted 6 days ago. Mar 31, 2025 - 04:14 PDT

Investigating

Dear Customers and Partners,

We are experiencing instability on our platform which could cause some delays in delivery.

Our team is investigating the issue and we will make sure to keep you updated as soon as we have preliminary findings.

If you have any questions, please contact us at support@telesign.com.
Posted 6 days ago. Mar 31, 2025 - 03:22 PDT
This incident affected: SMS/SMS Verify - EMEA (EMEA - All countries), SMS/SMS Verify - APAC (APAC - All countries), and SMS/SMS Verify - NA & LATAM (NA & LATAM - All countries).