Telesign system status

Telesign system status history

This page offers API uptime information for Telesign services, in addition to incident history reports and service issues alerts.

Active events

See more

Operational

Degraded performance

Partial Outage

Major Outage

Under maintenance

TeleSign API Intermittent Availability - Silent Verify

Incident Report for Telesign System

Resolved

Dear Customers and Partners,

Our Network Engineers have identified and successfully resolved this incident.

We would like to make it clear that this incident had no actual impact on our services from the customer's perspective. We stand by the reliability of our services and are committed to maintaining the highest standards for our clients.

If you have additional questions, please feel free to contact support@telesign.com.
Posted Jul 11, 2025 - 14:09 PDT

Investigating

Dear Customers and Partners,

We are currently experiencing a Silent Verify service disruption.

Our Network Engineers team is working to identify the root cause and implement a solution.

Once we have more information, we will make sure to update you.
Posted Jul 11, 2025 - 13:46 PDT
This incident affected: Verify API - Other channels (Silent Verify) and API Availability (Silent Verify).