Date: 05/11/26 Start Time: 07:40 AM PDT End Time: 07:50 AM PDT
We received notification that the issue with the Phone ID Contact Match, Number Deact, Sub Status and Sim Swap addon products is now resolved.
Thank you for your patience
Posted May 11, 2026 - 07:52 PDT
Investigating
Dear Customers, Please note that we are expecting a downtime in PID Contact Match, Number Deact, Sub Status and Sim Swap addon products, we will inform you when it is resolved.
Thank you for your patience and apologies for any inconvenience. Start Time: 07:40 AM PDT
Posted May 11, 2026 - 07:39 PDT
This incident affected: Phone ID Contact - EMEA (EMEA - All countries), Phone ID Contact - APAC (APAC - All countries), Phone ID Contact - NA & LATAM (NA & LATAM - All countries), and API Availability (Phone ID, Phone ID Contact, Phone ID Live, Phone ID Number deactivation, Phone ID Porting status, Phone ID SIM swap).