Telesign system status

Telesign system status history

This page offers API uptime information for Telesign services, in addition to incident history reports and service issues alerts.

Active events

See more

Operational

Degraded performance

Partial Outage

Major Outage

Under maintenance

Operator Service Alert - Quality degradation - United States (US) - ALL MNOs 05/02/25

Incident Report for Telesign System

Resolved

Start Time: 08:06 AM PDT - 05/02/25
End Time: 08:14 AM PDT - 05/02/25

We received notification that previously reported quality degradation toward United States (US) - ALL MNOs have been resolved. End users should no longer experience delays receiving SMS messages as all services are back to functioning properly.

SF case: 00988809
Posted May 02, 2025 - 08:46 PDT

Investigating

Issue: United States (US) - ALL MNOs Quality degradation

Date: 05/02/25
Start Time: 08:06 AM PDT
End Time: ongoing

Summary:
We currently experience quality degradation toward United States (US) - ALL MNOs. Customers that send SMS messages to United States (US) - ALL MNOs users may notice a difficulties in message delivery.
Our competent teams are working on solving this issue.

We'd like to apologize for any inconvenience and appreciate your patience during this service window.

If you have any questions, please contact us at support@telesign.com.

SF case: 00988809
Posted May 02, 2025 - 08:13 PDT
This incident affected: SMS/SMS Verify - NA & LATAM (United States).