Telesign system status

Telesign system status history

This page offers API uptime information for Telesign services, in addition to incident history reports and service issues alerts.

Active events

See more

Operational

Degraded performance

Partial Outage

Major Outage

Under maintenance

Service disruption for phone ID Phone ID - Live - United Kingdom (GB)

Incident Report for Telesign System

Resolved

04/02/2026
START: 01:14 AM PDT
END: 01:30 AM PDT

We are pleased to confirm that the issues affecting Phone ID – Live – United Kingdom have been fully resolved.
All services are now operating normally, and users should experience uninterrupted functionality.
We appreciate your patience while we worked to restore service.
Posted Apr 02, 2026 - 04:32 PDT

Monitoring

The previously reported issue is no longer present. We are actively monitoring the situation to confirm continued normal operation.
Posted Apr 02, 2026 - 02:53 PDT

Investigating

We have received notification that services for Phone ID - Live - United Kingdom are experiencing delays. We will inform you as soon as we receive a resolution.
Posted Apr 02, 2026 - 01:41 PDT
This incident affected: Phone ID Live - EMEA (United Kingdom).