Telesign system status

Telesign system status history

This page offers API uptime information for Telesign services, in addition to incident history reports and service issues alerts.

Active events

See more

Operational

Degraded performance

Partial Outage

Major Outage

Under maintenance

Intermittent issues for Phone ID - Number Deactivation Addon
Incident Report for Telesign System
Resolved
Start time: 06:41 PM PDT 01/14/2025
End time: 06:47 PM PDT 01/14/2025

Dear customers and partners,

We are glad to inform you that the previously reported delays in services for Phone ID - Number Deactivation Addon have been mitigated. We will continue to monitor to ensure long term stability.

If you have any questions or concerns, please feel free to contact us at support@telesign.com
Posted Jan 14, 2025 - 19:21 PST
Investigating
Dear Customers and Partners,

Our internal monitoring system shows intermittent delays for Phone ID - Number Deactivation Addon.

Our Network Operations Team is currently investigating and working on a speedy resolution.

We will inform you once the issue has been remedied.
Posted Jan 14, 2025 - 19:17 PST
This incident affected: Phone ID Number Deactivation - APAC (APAC - All countries), Phone ID Number Deactivation - EMEA (EMEA - All countries), and Phone ID Number Deactivation - NA & LATAM (NA & LATAM - All countries).