Telesign system status

Telesign system status history

This page offers API uptime information for Telesign services, in addition to incident history reports and service issues alerts.

Active events

See more

Operational

Degraded performance

Partial Outage

Major Outage

Under maintenance

Possible Delays

Incident Report for Telesign System

Resolved

This incident has been resolved.
Posted Feb 09, 2025 - 09:02 PST

Update

We are continuing to investigate this issue.
Posted Feb 09, 2025 - 09:01 PST

Update

Dear Customers and Partners,

Please note that the issue with the possible delays has been resolved.
Start Time: 08:27 AM PST
End Time: 08:28 AM PST

If you have any questions, please contact us at support@telesign.com.
Posted Feb 09, 2025 - 08:59 PST

Investigating

Dear Customers and Partners,

We are experiencing instability on our platform which could cause some delays in delivery.

Our team is investigating the issue and we will make sure to keep you updated as soon as we have preliminary findings.

If you have any questions, please contact us at support@telesign.com.
Posted Feb 09, 2025 - 08:57 PST
This incident affected: Phone ID Additional add-ons (Age verify, Breached number check, Call forward detection, Contact match, Contact plus, Device info, Subscriber status), Phone ID Porting Status - EMEA (EMEA - All countries), Phone ID SIM Swap - NA & LATAM (NA & LATAM - All countries), Phone ID SIM Swap - APAC (APAC - All countries), Phone ID SIM Swap - EMEA (EMEA - All countries), Phone ID Porting History - EMEA (EMEA - All countries), Phone ID Porting History - NA & LATAM (NA & LATAM - All countries), Phone ID Contact - EMEA (EMEA - All countries), Phone ID Contact - APAC (APAC - All countries), Phone ID Contact - NA & LATAM (NA & LATAM - All countries), Phone ID Live - EMEA (EMEA - All countries), Phone ID Live - APAC (APAC - All countries), Phone ID Live - NA & LATAM (NA & LATAM - All countries), Phone ID Number Deactivation - APAC (APAC - All countries), Phone ID Number Deactivation - EMEA (EMEA - All countries), Phone ID Number Deactivation - NA & LATAM (NA & LATAM - All countries), Phone ID Porting Status - NA & LATAM (NA & LATAM - All countries), Phone ID Porting Status - APAC (APAC - All countries), Phone ID - EMEA (EMEA - All countries), Phone ID - APAC (APAC - All countries), Phone ID - NA & LATAM (NA & LATAM - All countries), and Phone ID Porting History - APAC (APAC - All countries).