Telesign system status

Telesign system status history

This page offers API uptime information for Telesign services, in addition to incident history reports and service issues alerts.

Active events

See more

Operational

Degraded performance

Partial Outage

Major Outage

Under maintenance

Service disruption for phone ID Sim Swap Brazil

Incident Report for Telesign System

Resolved

Date: 04/02/25
Start Time: 04:00 PST
End Time: 05:30 PST


We received notification from our partner that the issue previously noticed in Brazil has been resolved. End users should no longer experience delays, as all services are back to functioning properly.

We apologize for any inconvenience this issue may have caused. If you have additional questions, please feel free to contact support@telesign.com.
Posted Apr 02, 2025 - 08:37 PDT

Investigating

Date: 04/02/25
Start Time: 04:00 PST
End Time: Ongoing

We received notification from our partner that Sim Swap is currently having issues in Brazil, which may cause some delays. We will inform you once there is a resolution.

We'd like to apologize for any inconvenience and appreciate your patience during this service window.

If you have any questions, please contact us at support@telesign.com.
Posted Apr 02, 2025 - 07:44 PDT
This incident affected: Phone ID SIM Swap - NA & LATAM (Brazil).