Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 11, 2026 - 05:45 PDT
Scheduled
As part of our ongoing platform modernization efforts, we are migrating the underlying Intelligence service used by Verify+ from our on-prem infrastructure to our cloud platform, throughout June.
This is a backend infrastructure change that will be performed entirely by Telesign and does not require any action from your team. No API, integration, configuration, or workflow changes are needed on your side.
We do not expect any impact to service functionality or user experience as a result of this migration. Verify+ will continue to operate as it does today while benefiting from the long-term scalability, reliability, and operational improvements of our cloud platform.
If you have any questions, please reach out to your Telesign representative.
Posted Jun 11, 2026 - 05:37 PDT
This scheduled maintenance affects: Intelligence (Intelligence).