Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 27, 2026 - 02:36 PDT
Scheduled
Description:
Who is affected: Customers using SMPP protocol Products affected: Inbound SMS
Current Implementation/Problem: We receive TON/NPI values from downstream providers and we pass those same values in the MO DeliverSm message to our SMPP customers. Sometimes providers send incorrect TON/NPI values in the MO DeliverSm message that we then pass along to our SMPP customers without modification, potentially causing incorrect identification, processing, logging, or storage of MO DeliverSm messages by a customer.
Hotfix Changes: With this hotfix we are planning to apply the following TON/NPI value mappings based on the type of sender that end users are sending SMS MOs to:
Empty sender = TON: 0, NPI: 0
Sender starts with '+' and all other characters are digits = TON: 1, NPI: 1
Alphanumeric sender = TON: 5, NPI: 0
Sender starts with 0 or starts with length in (0, 8), typically associated with short codes = TON: 2, NPI: 1
Sender starts with length in (8, ∞), typically associated with long codes = TON: 1, NPI: 1
The hotfix consists of code in our internal system that will force all received TON/NPI value mappings from providers to change to the above values. This code will automatically run prior to submission of each MO DeliverSm message to our SMPP customers.
How this may affect you: Customers using SMPP:
Customers with numeric senders, such as dedicated short codes (DSCs) or dedicated long codes (DLCs), and that receive inbound SMS messages via the SMPP protocol, and that hardcode TON/NPI values for their DLCs or DSCs, may be affected by the hotfix TON/NPI logic changes and may need to perform code changes to their SMPP configuration.
Customers that don't hardcode the TON/NPI values should not be affected, but may still need to update their database value mappings to match the new mapped values as noted above.
Customers using API:
Customers using Messaging API, SMS API, or SMS Verify API: No action is required if you use one of our API products to receive inbound SMS MO messages.
If you have questions or need assistance, contact your Customer Success Manager or Customer Support.
Posted Aug 27, 2026 - 02:35 PDT
This scheduled maintenance affects: SMS/SMS Verify - EMEA (EMEA - All countries), SMS/SMS Verify - APAC (APAC - All countries), and SMS/SMS Verify - NA & LATAM (NA & LATAM - All countries).