Telesign system status

Telesign system status history

This page offers API uptime information for Telesign services, in addition to incident history reports and service issues alerts.

Active events

See more

Operational

Degraded performance

Partial Outage

Major Outage

Under maintenance

Voice and Voice API Quality Degradation towards United Arab Emirates (AE) - 02/03/25
Incident Report for Telesign System
Resolved
Start Time: 12:10AM PST - 02/03/25
End Time: 03:10AM PST - 02/03/25

We received notification that the network issues previously reported towards United Arab Emirates (AE) have been resolved. End users should no longer experience delays in receiving Voice and Voice API transactions as all services are back to functioning properly.

SF 00946591
Posted Feb 03, 2025 - 04:47 PST
Investigating
Start Time: 12:10AM PST - 02/03/25
End Time: Ongoing

Summary:

We received notification that ALL mobile network operators from United Arab Emirates (AE) are currently experiencing network issues, and this may cause a latency in Voice and Voice API transactions. We will inform you once the operator has come to a resolution.
If you have any questions, please contact us at support@telesign.com.

SF 00946591
Posted Feb 03, 2025 - 01:00 PST
This incident affected: Voice Verify - EMEA (EMEA - All countries, U.A.E.) and Voice - EMEA (EMEA - All countries).