Telesign system status

Telesign system status history

This page offers API uptime information for Telesign services, in addition to incident history reports and service issues alerts.

Active events

See more

Operational

Degraded performance

Partial Outage

Major Outage

Under maintenance

Service Alert: WhatsApp Message Delivery Issues

Incident Report for Telesign System

Resolved

Dear Customers and Partners,

WhatsApp message delivery has now been restored as of 10:15 AM PDT.

We apologize for any inconvenience that this may have caused. If you have any further questions, feel free to reach out to support@telesign.com
Posted Apr 30, 2025 - 10:56 PDT

Update

We are continuing to investigate this issue.
Posted Apr 30, 2025 - 03:50 PDT

Investigating

Dear Customers and Partners,
We detected a downstream issue that might cause delays in the delivery of WhatsApp messages.
Our team is investigating the issue, and we will update you as soon as we have preliminary findings.
Start time: 04-30-2025 01:26 AM UTC+0
If you have any questions, please contact us at support@telesign.com.
Posted Apr 29, 2025 - 23:31 PDT
This incident affected: Messaging API - Other channels (WhatsApp).