Telesign system status

Telesign system status history

This page offers API uptime information for Telesign services, in addition to incident history reports and service issues alerts.

Active events

See more

Operational

Degraded performance

Partial Outage

Major Outage

Under maintenance

Quality degradation - United States (US) - Verizon Wireless (310/004;006;010;012;590)

Incident Report for Telesign System

Resolved

Issue: United States (US) - Verizon Wireless (310/004;006;010;012;590) - Quality degradation

Start Time: 02:17PM PDT - 05/12/25
End Time: 3:10PM PDT - 05/12/25

Summary:

The issue affecting SMS delivery to United States (US) - Verizon Wireless has been resolved.

If you have any questions, please contact support@telesign.com.

SF 00993351
Posted May 12, 2025 - 17:33 PDT

Investigating

Issue: United States (US) - Verizon Wireless (310/004;006;010;012;590) - Quality degradation

Start Time: 02:17PM PDT - 05/12/25
End Time: [TIMESTAMP IN PST] - MM/DD/YY

Summary:

We currently experience quality degradation toward United States (US) - Verizon Wireless (310/004;006;010;012;590)
SMS messages towards these operator(s) may face delays or difficulties in delivery.

Telesign is engaged with carrier partners for updates on resolution. We'd like to apologize for any inconvenience and appreciate your patience during this service interruption.

If you have any questions, please contact support@telesign.com.

SF 00993351
Posted May 12, 2025 - 14:51 PDT
This incident affected: SMS/SMS Verify - NA & LATAM (NA & LATAM - All countries, United States).