We received notification that the network issues previously reported by multiple operators from United Kingdom (GB) have been resolved. End users should no longer experience delays receiving SMS messages as all services are back to functioning properly.
SF 00972943
Posted Mar 31, 2025 - 12:06 PDT
Investigating
Issue: Operator - United Kingdom (GB) - Multiple MNOs
Start Time: 01:53AM PST - 03/31/25 End Time: Ongoing
Summary:
We received notification that Multiple MNOs from United Kingdom (GB) are currently experiencing network issues, and this may cause a delay in the delivery of SMS messages.
Telesign is engaged with the operators for updates on resolution.
We'd like to apologize for any inconvenience and appreciate your patience during this service interruption. If you have any questions, please contact support@telesign.com.
SF 00972943
Posted Mar 31, 2025 - 02:40 PDT
This incident affected: SMS/SMS Verify - EMEA (United Kingdom).