We will be undergoing scheduled maintenance during this time.
Posted Oct 02, 2025 - 08:55 PDT
Update
We will be undergoing scheduled maintenance during this time.
Posted Sep 24, 2025 - 13:26 PDT
Update
We will be undergoing scheduled maintenance during this time.
Posted Sep 22, 2025 - 13:58 PDT
Scheduled
Effective October 1st, 2025, Operator Claro has mandated that all traffic must complete Sender ID registration to ensure message delivery.
Starting October 1st, clients are required to begin registering their SenderIDs. However, please note that unregistered and generic SenderIDs will not be blocked until November 1st. During this transition period, traffic delivery will not be impacted, but we strongly encourage all clients to complete their senderID registration ahead of he November deadline.
Required Details:
*Registration ETA: 7 Days
Sender ID Message sample Company name Traffic Type (OTP/ARN/MKT) Company website (URL) Industry Type ✅ Action Required:
Please submit your requests with the information as soon as possible by going to your My Telesign portal or sending the necessary information to Support@telesign.com
Thank you for your attention to this critical update.
Posted Sep 22, 2025 - 13:46 PDT
This scheduled maintenance affects: Regulatory Updates (NA & LATAM).