Start Time: 07:29 AM PDT - 5/16/25 End Time: 09:09 AM PDT - 5/16/25
We received notification that the network issues previously reported by Israel (IL) - Pelephone Communications Ltd (425/03;16;18) from Israel (IL) have been resolved. Israel (IL) - Pelephone Communications Ltd (425/03;16;18) end users should no longer experience delays receiving SMS messages as all services are back to functioning properly.
SF 00996021
Posted May 16, 2025 - 09:35 PDT
Investigating
Start Time: 07:29 AM PDT - 5/16/25 End Time: Ongoing
We received notification that Israel (IL) - Pelephone Communications Ltd (425/03;16;18) from Israel (IL) - is currently experiencing network issues, and this may cause a delay in the delivery of SMS messages. We will inform you once the operator has come to a resolution.
SF 00996021
Posted May 16, 2025 - 07:33 PDT
This incident affected: SMS/SMS Verify - EMEA (EMEA - All countries).