System Status


This page offers API uptime information for Telesign services, in addition to incident history reports and service issues alerts.
Phone ID Contact Match addon Intermittent issues - Canada
Incident Report for Telesign system status
Resolved
Start time: 11:50 PM PDT 10/08/2024
End time: 12:20 AM PDT 10/09/2024

Dear customers and partners,

We are glad to inform you that the previously reported delays in services for Phone ID Contact Match addon for Canada have been mitigated. We will continue to monitor to ensure long term stability.

If you have any questions or concerns, please feel free to contact us at support@telesign.com
Posted Oct 09, 2024 - 02:49 PDT
Investigating
Dear Customers and Partners,

Our internal monitoring system shows intermittent Phone ID Contact Match addon delays starting at 11:50 PM PDT 10/08/2024.

Our Network Operations Team is currently investigating and working on a speedy resolution.

We will inform you once the issue has been remedied.
Posted Oct 09, 2024 - 00:30 PDT
This incident affected: Enterprise Services (PhoneID Standard, PhoneID Contact).