System Status


This page offers API uptime information for Telesign services, in addition to incident history reports and service issues alerts.

Service Metrics

Kuwait Ooredoo introduced monthly Sender ID Registration fees
Incident Report for Telesign system status
Resolved
This incident has been resolved.
Posted Oct 13, 2022 - 02:18 PDT
Identified
Country: Kuwait

Operator: Ooredoo

Effective Date: 1st of August

Details: Starting from the 1st of August 2021, there will be a monthly fee of 50 USD per each whitelisted Sender ID to operator Ooredoo Kuwait, for both local and international traffic. This fee will be applied only for OTP/TRANS traffic and not for Marketing. The fee is for both existing and new whitelisted Sender IDs.
Posted Jul 12, 2021 - 08:18 PDT
This incident affected: Regulatory Updates.