System Status


This page offers API uptime information for Telesign services, in addition to incident history reports and service issues alerts.
📢 Important Update: TCR Authentication Plus for Public Profit Brands
Incident Report for Telesign system status
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 15, 2024 - 12:45 PDT
Investigating
Starting October 17, 2024, The Campaign Registry (TCR) is launching a new brand identity verification process called Authentication+ to prevent fraud like impersonation, smishing, and spoofing. This will apply first to all brands with a Public Profit entity type. The process includes Two-Factor Authentication (2FA) as part of the brand registration. Future updates will expand support for additional entity types, and it will also lay the groundwork for RCS verification.

What You Need to Know:
Public Profit brands must complete a new 2FA step during registration starting October 17, 2024.
A 2FA email will be sent to the "Brand Contact Email" with a link and PIN code.
The brand contact must provide their first name, last name, job title, and the PIN from the email to complete the verification.
Once verified, the brand will be marked as VERIFIED and can create 10DLC campaigns.

Important Deadlines:
If the 2FA email link is not used within 7 days, you can request a new email. The verification must be completed within 30 days or the brand will become "unverified," requiring a new registration.
Existing Public Profit brands must update their brand contact email and complete the 2FA process by October 17, 2024, to avoid losing the ability to register new campaigns.
Current active campaigns won't be affected immediately, but a future deadline will be announced for compliance.

Make sure to complete the verification by the October 17 deadline to avoid any disruptions
Posted Oct 15, 2024 - 12:44 PDT
This incident affects: Regulatory Updates.