System Status


This page offers API uptime information for TeleSign services, in addition to incident history reports and service issues alerts.
Service Alert - TeleSign Ticketing Portal
Incident Report for TeleSign System Status
Resolved
Dear Customers and Partners,

A previously reported issue impacting TeleSign ticketing portal is now resolved. All services are now operating as expected.

We apologize for this interruption and for any impact on you or your customers.

Please feel free to contact support@telesign.com for any additional questions or inquiries.
Posted May 11, 2021 - 17:47 PDT
Identified
Dear Customers and Partners,

We are currently experiencing a service discrepancy affecting our ticketing portal.

We are working on identifying the root cause and implementing a resolution.

Once we have more information, we will make sure to update you.
Posted May 11, 2021 - 15:23 PDT
This incident affected: Operator Alerts.