System Status


This page offers API uptime information for Telesign services, in addition to incident history reports and service issues alerts.

Service Metrics

Unified Portal Unreachable
Incident Report for Telesign system status
Resolved
Dear Customers and Partners,

Previously reported issues with our platform have been resolved. If you have additional questions, please feel free to contact support@telesign.com.
Posted Jun 16, 2021 - 17:14 PDT
Investigating
Dear Customers and Partners,

We are experiencing instability on our platform which could cause problems in reaching TeleSign Portal. Our team is investigating the issue and we will make sure to keep you updated as soon as we have preliminary findings.

If you have any questions, please contact us at support@telesign.com.
Posted Jun 16, 2021 - 15:41 PDT