System Status


This page offers API uptime information for Telesign services, in addition to incident history reports and service issues alerts.

Service Metrics

🚨 Important Update: New TFN Regulations Effective January 31, 2024! 🚨
Incident Report for Telesign system status
Update
We are continuing to investigate this issue.
Posted Nov 29, 2023 - 12:56 PST
Investigating
🚨 Important Update: New TFN Regulations Effective January 31, 2024! 🚨

Attention valued customers! As of January 31, 2024, regulatory changes will take effect. Currently, you are able to send messages through pending toll-free phone numbers, provided they adhere to existing industry-wide sending limits. However, starting January 31, 2024, messages originating from toll-free phone numbers still in the pending verification process will be blocked.

In anticipation of these changes, we kindly request you to keep in mind the importance of the dates mentioned. We appreciate your understanding and cooperation as we navigate this transition.
Posted Nov 29, 2023 - 12:55 PST
This incident affects: Regulatory Updates.