System Status


This page offers API uptime information for Telesign services, in addition to incident history reports and service issues alerts.

Service Metrics

Renew an SSL/TLS certificate - July 2024
Incident Report for Telesign system status
Update
We are continuing to work on a fix for this issue.
Posted Jul 10, 2024 - 02:15 PDT
Identified
Dear Customers and Partners,

The SSL certificate for *.callback.telesign.com will soon expire. Our dedicated teams will work on certificate replacement from July 22nd to July 25th.

Certificate pinning is not a best practice and is not explicitly supported by Telesign, which can cause outages. https://developer.telesign.com/enterprise/docs/authentication#tls-and-certificates

All Digicert Roots and Intermediate certificates can also be found and downloaded directly from their site: https://www.digicert.com/kb/digicert-root-certificates.htm#roots

Thank you.

Please do not hesitate to contact us at support@telesign.com with any questions or concerns.
Posted Jul 09, 2024 - 07:59 PDT
This incident affects: Regulatory Updates.