System Status


This page offers API uptime information for Telesign services, in addition to incident history reports and service issues alerts.

Service Metrics

SMS Delivery Delay - non-US traffic
Incident Report for Telesign system status
Resolved
Dear Customers and Partners,

This is to inform you that reported issue regarding SMS delivery delays on ALL non-US traffic has been resolved at 11:20 AM PDT.

Our tests show positive delivery now and no degradation in quality.

If you need more information, please contact support@telesign.com
Posted Oct 05, 2019 - 11:15 PDT
Investigating
Dear Customers and Partners,

Our internal monitoring system shows intermittent SMS delivery delays on ALL non-US traffic starting at 10:52AM PDT.

Our Network Operations team is currently investigating and working on a speedy resolution.

We will inform you once the issue has been remedied.
Posted Oct 05, 2019 - 10:45 PDT
This incident affected: Enterprise Services (SMS & SMS Verify) and Standard Services (SMS).