System Status


This page offers API uptime information for Telesign services, in addition to incident history reports and service issues alerts.

Service Metrics

Tanzania operator TTCL registrations on hold
Incident Report for Telesign system status
Resolved
This incident has been resolved.
Posted Oct 13, 2022 - 02:03 PDT
Identified
Country: Tanzania

Operator: TTCL

Effective Date: Already started

Details: All Sender ID registrations are on hold for the network TTCL Tanzania, there is no ETA for registrations to be resumed.
Posted Mar 25, 2022 - 04:44 PDT
This incident affected: Regulatory Updates.