System Status


This page offers API uptime information for Telesign services, in addition to incident history reports and service issues alerts.

Service Metrics

Possible Delays in delivery
Incident Report for Telesign system status
Resolved
Dear Customers and Partners,

We are able to confirm communication & data products delivery has been stabilized as of 06:15 PM PST on January 5th.

Affected Time Frames are as bellow:

Issue Started - Date: January 5th, 2021 Time: 01:34 PM PST
Platform Stabilized - Date: January 5th, 2021 Time: 06:15 PM PST
Issue Resolved - Date: January 6th, 2021 Time: 07:38 AM PST

We apologize for any inconvenience this issue may have caused. If you have additional questions, please feel free to contact support@telesign.com
Posted Jan 11, 2021 - 12:43 PST
Update
We can confirm that we do not observe increased latency as of 07:45 AM PST. Teams keep monitoring and investigating this closely and updates will be posted accordingly.
Posted Jan 06, 2021 - 18:04 PST
Monitoring
Dear Customers and Partners,

We experienced a long-lasting issue with one of our CDN providers. Issue is isolated and in the last hour we do not experience issue anymore.
Team works hard on resolution and we will update you once issue is finally resolved.
Posted Jan 06, 2021 - 09:04 PST
Update
We are continuing to investigate this issue.
Posted Jan 06, 2021 - 08:42 PST
Update
We are continuing to investigate this issue.
Posted Jan 06, 2021 - 07:38 PST
Update
We are continuing to investigate this issue.
Posted Jan 06, 2021 - 06:35 PST
Update
We are continuing to investigate this issue.
Posted Jan 06, 2021 - 05:35 PST
Update
We are continuing to investigate this issue.
Posted Jan 06, 2021 - 04:24 PST
Update
We are continuing to investigate this issue.
Posted Jan 06, 2021 - 03:22 PST
Update
We are continuing to investigate this issue.
Posted Jan 06, 2021 - 02:14 PST
Update
We are continuing to investigate this issue.
Posted Jan 06, 2021 - 01:11 PST
Update
We are continuing to investigate this issue.
Posted Jan 05, 2021 - 23:48 PST
Update
We are continuing to investigate this issue.
Posted Jan 05, 2021 - 22:43 PST
Update
Dear Customers and Partners,

We still experiencing instability on our platform which could cause some delays in delivery.

Our team is working on this issue. We will keep you updated about our investigation.
Posted Jan 05, 2021 - 21:37 PST
Update
Dear Customers and Partners,

This incident is still under investigation.

As soon as we receive any update, we will inform you.
Posted Jan 05, 2021 - 20:09 PST
Update
Dear Customers and Partners,

We are continuing to investigate this issue.
Posted Jan 05, 2021 - 19:05 PST
Update
Dear Customers and Partners,

We still experiencing instability on our platform which could cause some delays in delivery.

Our team is working on this issue. We will keep you updated about our investigation.
Posted Jan 05, 2021 - 17:46 PST
Update
Dear Customers and Partners,

This incident is still under investigation.

As soon as we receive any update, we will inform you.
Posted Jan 05, 2021 - 16:43 PST
Update
We are continuing to investigate this issue.
Posted Jan 05, 2021 - 15:47 PST
Update
Dear Customers and Partners,

Our network team are still investigating root cause of this issue. We will keep you updated about our investigation.

Thank you for patience.
Posted Jan 05, 2021 - 15:41 PST
Investigating
Dear Customers and Partners,

We are experiencing instability on our platform which could cause some delays in delivery.

Our team is investigating the issue and we will make sure to keep you updated as soon as we have preliminary findings.

If you have any questions, please contact us at support@telesign.com.
Posted Jan 05, 2021 - 13:55 PST
This incident affected: Enterprise Services (SMS & SMS Verify, Voice Verify, Smart Verify, Push Verify, PhoneID Standard, PhoneID Contact, PhoneID Live, Score) and Standard Services (SMS, Voice, PhoneID, Score, App Verify).