System Status


This page offers API uptime information for Telesign services, in addition to incident history reports and service issues alerts.

Service Metrics

Possible Delays - Global
Incident Report for Telesign system status
Resolved
Dear Customers and Partners,

Delivery has now been restored as of 04/31/2023 at 01:25 am PDT.

We are currently reviewing the root cause and will provide additional information once we have completed the investigation.

Start time: 01:00 am PDT.
End time: 01:25 am PDT.
Posted May 31, 2023 - 01:27 PDT
Investigating
Dear Customers and Partners,

We are experiencing instability on our platform which could cause some delays in delivery.

Our team is investigating the issue and we will make sure to keep you updated as soon as we have preliminary findings.

If you have any questions, please contact us at support@telesign.com.
Posted May 31, 2023 - 01:11 PDT
This incident affected: Enterprise Services (SMS & SMS Verify) and Standard Services (SMS).