System Status


This page offers API uptime information for Telesign services, in addition to incident history reports and service issues alerts.

Service Metrics

UK SID Whitelisting Introduced
Incident Report for Telesign system status
Update
We are continuing to work on a fix for this issue.
Posted Feb 29, 2024 - 09:07 PST
Identified
📢 Dear valued clients, we bring you a crucial update! To streamline operations in the UK, SID approval/whitelist is now a prerequisite. Going forward, it is imperative for the end client or brand to provide the following details:

1. Sender ID (case sensitive)
2. Message Content Sample (including any URLs if present in the content)
3. Expected Monthly Volume

Generic SIDs are no longer allowed.

Your cooperation in meeting these requirements is highly appreciated.
Posted Feb 29, 2024 - 08:54 PST
This incident affects: Regulatory Updates.