System Status


This page offers API uptime information for Telesign services, in addition to incident history reports and service issues alerts.

Service Metrics

Support Phone Line Issues
Incident Report for Telesign system status
Resolved
Dear customers and partners,

Issue affecting our phone support lines was resolved. We sincerely apologize for any inconvenience this may have caused. If you have any additional questions, please feel free to contact support@telesign.com or your Customer Success Representative.
Posted Mar 29, 2021 - 12:12 PDT
Investigating
Dear Customers and Partners,

We are experiencing difficulties with our telephone support lines and are working diligently to resolve the issue. Until then please reach out with any needs via support@telesign.com or directly with your Customer Success Representative.

Please accept our sincere apologies while we're working on getting this resolved.
Posted Mar 26, 2021 - 18:13 PDT
This incident affected: Enterprise Services (SMS & SMS Verify, Voice Verify, Smart Verify, Push Verify, PhoneID Standard, PhoneID Contact, PhoneID Live, Score), Operator Alerts (Operator Alerts WW), and Standard Services (SMS, Voice, PhoneID, Score, App Verify).