System Status

This page offers API uptime information for TeleSign services, in addition to incident history reports and service issues alerts.
SMS Delivery Delay - International
Incident Report for TeleSign System Status
Resolved
Dear Customers and Partners,

SMS delivery has now been restored as of 08:46 PDT.

We are currently reviewing root cause and will provide additional information once we have completed the investigation.
Posted 12 days ago. Feb 08, 2019 - 09:12 PST
Identified
Dear Customers and Partners,

Our internal monitoring system shows intermittent SMS delivery delays on ALL non-US traffic starting at 06:02 PDT

Our Network Operations team is currently investigating and working on a speedy resolution.

We will inform you once the issue has been remedied.
Posted 12 days ago. Feb 08, 2019 - 08:37 PST
This incident affected: Enterprise Services (SMS Verify) and Standard Services (SMS).