System Status


This page offers API uptime information for Telesign services, in addition to incident history reports and service issues alerts.

Service Metrics

Service degradation - PhoneID Contact
Incident Report for Telesign system status
Resolved
Dear Customers and Partners,

Previously reported issues with PhoneID Contact have been resolved.

Start Time: 05/06/24 at 01:00 AM PDT
End Time: 05/07/24 at 02:44 PM PDT

We apologize for any inconvenience this issue may have caused. If you have additional questions, please feel free to contact support@telesign.com.
Posted May 07, 2024 - 15:01 PDT
Investigating
Dear Customers and Partners,

Telesign has detected downstreaming issues with PhoneID Contact.

We are actively working on resolving this.

As soon as we get more details, we will let you know.

Meanwhile, please do not hesitate to contact us on support@telesign.com for any additional details.
Posted May 07, 2024 - 12:33 PDT
This incident affected: Enterprise Services (PhoneID Contact) and Standard Services (PhoneID).