System Status


This page offers API uptime information for Telesign services, in addition to incident history reports and service issues alerts.

Service Metrics

Possible Delays
Incident Report for Telesign system status
Resolved
Dear Customers and Partners,

This is to inform you that reported instability on our platform has been resolved.

All services are up and running normally now.

If you have any questions, please contact us at support@telesign.com.
Posted Sep 17, 2021 - 10:18 PDT
Investigating
Dear Customers and Partners,

We are experiencing instability on our platform which could cause some delays in delivery.

Our team is investigating the issue and we will make sure to keep you updated as soon as we have preliminary findings.

If you have any questions, please contact us at support@telesign.com.
Posted Sep 17, 2021 - 08:40 PDT
This incident affected: Enterprise Services (SMS & SMS Verify) and Standard Services (SMS).