System Status


This page offers API uptime information for Telesign services, in addition to incident history reports and service issues alerts.

Service Metrics

Difficulties with TeleSign's telephone support lines
Incident Report for Telesign system status
Resolved
Dear Customers and Partners,

Please note that we are not experiencing any issues with our telephone support lines which are now working as intended.

Thank you.
Posted Sep 09, 2020 - 19:15 PDT
Investigating
Dear Customers and Partners,

We are experiencing difficulties with our telephone support lines and are working diligently to resolve the issue.

Until then please reach out with any needs via support@telesign.com or directly with your Customer Success Representative.

Thank you.
Posted Sep 09, 2020 - 09:04 PDT
This incident affected: Operator Alerts (Operator Alerts WW).