System Status

This page offers API uptime information for TeleSign services, in addition to incident history reports and service issues alerts.
Operator Service Alert United States - Multiple Small US Carriers
Incident Report for TeleSign System Status
Resolved
Date: 05/10/2019
Start Time: 11:30 AM PDT
End Time: 03:48 PM PDT

We received notification that the network issues previously reported by C Spire Wireless (aka Cellular South) USA and Google Voice USA have been resolved. C Spire Wireless (aka Cellular South) USA and Google Voice USA end-users should no longer experience delays receiving SMS messages as all services are back to functioning properly.

On behalf of the Operator, we apologize for any inconvenience this issue may have caused. If you have additional questions, please feel free to contact support@telesign.com.
Posted 12 days ago. Oct 05, 2019 - 16:23 PDT
Identified
Date: 05-10-2019
Start Time: 11:30 PDT
End Time: Ongoing

We received notification that C Spire Wireless (aka Cellular South) USA and Google Voice USA is currently experiencing network issues, and this may cause a delay in the delivery of SMS messages. We will inform you once the operators has come to a resolution.
Posted 13 days ago. Oct 05, 2019 - 12:14 PDT
This incident affected: Operator Alerts.