System Status

This page offers API uptime information for TeleSign services, in addition to incident history reports and service issues alerts.
Possible SMS messages delays towards Canada
Incident Report for TeleSign System Status
Resolved
This incident has been resolved.
Posted 21 days ago. Sep 27, 2019 - 10:38 PDT
Identified
.
Posted 25 days ago. Sep 23, 2019 - 10:29 PDT
Investigating
We have been notified by one of our Carrier Partners of an issue impacting the SMS services towards Canada. Their engineers are investigating the issue and working towards a resolution.

Start Date Time: 09/23/2019 12:20 PM ET

If you need any additional assistance, please contact support@telesign.com
Posted 25 days ago. Sep 23, 2019 - 10:28 PDT