System Status

This page offers API uptime information for TeleSign services, in addition to incident history reports and service issues alerts.
Status Alert - Message Delivery Delays
Incident Report for TeleSign System Status
Resolved
The incident has been resolved and traffic is being processed normally. We will continue to monitor.
Posted 3 months ago. Jan 31, 2019 - 07:49 PST
Monitoring
A fix has been implemented and changes were made at 05:08 AM PST to stabilize traffic. Queues are clearing and TeleSign engineers continue to monitor traffic and investigate the cause of the issue.
Posted 3 months ago. Jan 31, 2019 - 05:34 PST
Investigating
Date: 31 January 2019
Start Time: 04:45 AM PST
End Time: 05:08 AM PST

Dear Customers,

We are aware of message delivery delays currently being experienced on the TeleSign platform. All hands are currently investigating and taking measures to resolve the issue while the cause is investigated. We will update here as we know more. We apologize for any inconvenience.

Kind Regards,

TeleSign Support
Posted 3 months ago. Jan 31, 2019 - 05:14 PST
This incident affected: Enterprise Services (SMS Verify) and Standard Services (SMS).