System Status


This page offers API uptime information for Telesign services, in addition to incident history reports and service issues alerts.

Service Metrics

10DLC Update
Incident Report for Telesign system status
Resolved
This incident has been resolved.
Posted Oct 13, 2022 - 02:13 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 25, 2021 - 03:20 PDT
Investigating
With effect from 1 October, 2021, mobile providers will start enforcing 10DLCs for A2P SMS in the US. As such, providers now require all A2P SMS sent in the United States to be sent via 10DLC, DSC or TFN. All messages sent with a long code will be blocked and can incur significant fines and penalties will be imposed by the mobile carriers for non-compliance. You will be responsible for such fines and penalties if you do not comply.

If you are not sending any A2P SMS in the US or have your own dedicated sender (DSC, 10DLC, or TFN) for A2P SMS in US, you do not need to do anything.

Your immediate action is required if you are currently sending SMS in the US and have yet to register for a 10DLC, DSC or TFN. You can request a dedicated sender using the links below:

https://ts.telesign.com/10dlc-registration

https://ts.telesign.com/tfn-registration

https://ts.telesign.com/dsc-registration

If you are using long codes for A2P US traffic, and have yet to apply for a dedicated sender, contact us at support@telesign.com as soon as possible to ensure your SMS Services will not be disrupted past 1 October 2021. Our Team will guide you through the registration process and provide any other information that you may need.

PLEASE TAKE NOTE: Any A2P SMS traffic sent in the US without 10DLC, DSC, or TFN after 1 October, 2021 may not be delivered as we may suspend such traffic until the 10DLC requirement is complied with. For more information on 10DLC – check out our blog: https://www.telesign.com/blog/are-you-ready-for-10dlc
Posted Aug 25, 2021 - 03:20 PDT
This incident affected: Regulatory Updates.