System Status

This page offers API uptime information for TeleSign services, in addition to incident history reports and service issues alerts.
Operator Service Alert Yemen - Spacetel (MTN)
Incident Report for TeleSign System Status
Resolved
We received notification that the network issues previously reported by Spacetel (MTN)
from Yemen have been resolved. Spacetel (MTN) end users should no longer experience delays receiving SMS messages as all services are back to functioning properly.

On behalf of the Operator, we apologize for any inconvenience this issue may have caused. If you have additional questions, please feel free to contact support@telesign.com.
Posted 15 days ago. Jan 04, 2019 - 03:48 PST
Identified
We received notification that Spacetel (MTN) from Yemen is currently experiencing network issues, and this may cause a delay in the delivery of SMS messages. We will inform you once the operator has come to a resolution.
Posted about 1 month ago. Dec 16, 2018 - 06:06 PST
This incident affected: Operator Alerts.