System Status


This page offers API uptime information for Telesign services, in addition to incident history reports and service issues alerts.

Service Metrics

MTC Saudi Arabia needs additional NOC in order to register Sender IDs from local companies
Incident Report for Telesign system status
Resolved
This incident has been resolved.
Posted Oct 13, 2022 - 02:18 PDT
Identified
Country: Saudi Arabia

Operator: MTC Saudi Arabia (420/04)

Effective Date: Already started

Details: All the local vendors in Saudi Arabia now need the NOC on their name directly from the customer due to local norms to avoid potential penalties.
Posted May 14, 2021 - 03:26 PDT
This incident affected: Regulatory Updates.