System Status

This page offers API uptime information for TeleSign services, in addition to incident history reports and service issues alerts.
Operator Service Alert Saudi Arabia - MTC Saudi Arabia (Zain SA) 420/04
Incident Report for TeleSign System Status
Resolved
We received notification that the network issues previously reported by MTC Saudi Arabia (Zain SA) from Saudi Arabia have been resolved. MTC Saudi Arabia (Zain SA) end-users should no longer experience delays receiving SMS messages as all services are back to functioning properly.

Start Date and Time 31 Jul 2019 01:50 AM PDT
End Date and Time 31 Jul 2019 05:07 AM PDT

On behalf of the Operator, we apologize for any inconvenience this issue may have caused. If you have additional questions, please feel free to contact support@telesign.com.
Posted Jul 31, 2019 - 06:28 PDT
Identified
We received notification that MTC Saudi Arabia (Zain SA) from Saudi Arabia is currently experiencing network issues, and this may cause a delay in the delivery of SMS messages. We will inform you once the operator has come to a resolution.
Posted Jul 31, 2019 - 03:14 PDT
This incident affected: Operator Alerts.