System Status


This page offers API uptime information for Telesign services, in addition to incident history reports and service issues alerts.

Service Metrics

Qualification Policy Change for 10DLC
Incident Report for Telesign system status
Resolved
This incident has been resolved.
Posted Oct 13, 2022 - 02:14 PDT
Identified
Country: USA

Operator: all

Effective date: 29th of July

Details: Starting from the 29th of July, there is a policy change for 10DLC. As mandated by MNOs, Brand Registration Score (0-100) will be replaced by Brand Identity Status (Verified/Unverified) because of Brand Registration. The "Verified" status is acquired by a Brand whose EIN/Tax-id matches their Legal Company. Being identified as a "Verified" Brand is now a requirement for messaging on 10DLC. The brands with “Unverified” status (EIN/Tax-id not matching with Legal Company Name) should be resubmitted for identity check (there is a $4 fee for identity check).
Previously registered Brands will be automatically checked without any additional fee and their status displayed on the "Brand details" page.
Campaigns from “Unverified” Brands will remain in a “grace period” until further notice from MNOs, after which they will not be able to run on 10DLC unless the Brand is re-registered and obtains the "Verified" status.
Posted Jul 29, 2021 - 01:59 PDT
This incident affected: Regulatory Updates.