System Status


This page offers API uptime information for Telesign services, in addition to incident history reports and service issues alerts.

Service Metrics

SMS service degradation affecting Cellsouth(C-Spire), USA
Incident Report for Telesign system status
Resolved
Dear Customers,

Our monitoring have confirmed the issue impacting the delivery of messages towards Cellsouth(C-Spire), USA is resolved.
All services are operating as expected since 2020-05-13 19:00:00 PDT.


Issue start time: 2020-05-13 14:10:00 PDT
Issue resolve time: 2020-05-13 19:00:00 PDT


We apologies on behalf of the carrier for this interruption and for any impact to you or your customers.

Please contact support@telesign.com if you have any further questions.
Posted May 13, 2020 - 20:13 PDT
Investigating
Dear Customers,

Since 2020-05-13 14:10:00 PDT Cellsouth(C-Spire), USA have been experiencing an issue with their SMS service.

As a result of this issue, a portion of MO/MT SMS messages are not being received by subscribers on the affected carrier.

The Carrier is aware of this issue and are working to resolve it as soon as possible. Please accept our apologies on behalf of the carrier for any inconvenience or impact this may have to your business.

Please contact support@telesign.com if you need more details.
Posted May 13, 2020 - 19:19 PDT