System Status


This page offers API uptime information for Telesign services, in addition to incident history reports and service issues alerts.

Service Metrics

10DLC update – T-Mobile fees
Incident Report for Telesign system status
Resolved
This incident has been resolved.
Posted Oct 13, 2022 - 02:12 PDT
Identified
Country: USA

Operator: T-Mobile

Effective Date: 1st of December

Details:

T-Mobile has changed the effective date for the $50 10DLC Campaign Service Activation & Campaign Service Migration Fee to the 1st of December 2021. (previously the effective date for this was 1st of October)

However, effective October 1, 2021, T-Mobile will begin charging the following fees:

• NNID Registration - $2,000

• Text Enablement -$10,000 (if a company or a Message Sender, text-enables a 10-digit NANP telephone number and sends messages prior to verification of Message Sender ownership);

• 10-Digit Long Code Messaging Program Evasion - $1,000 (for each unique instance of a violation: Snowshoe sending, dynamic routing, spam filter evasion, unapproved campaign service);

• Content Violation - $10,000 (for each of the third and any subsequent notification of a Content Violation involving the same Content Provider);
Posted Oct 04, 2021 - 02:26 PDT
This incident affected: Regulatory Updates.